Jump to content

The specified module could not be found...


Recommended Posts


I'am making a forge mod with this library : https://github.com/MinnDevelopment/java-discord-rpc

When i run Minecraft Client on IntelliJ, it works but when i build the mod and i put it on my mod's folder and i run my minecraft launcher i have this error : https://pastebin.com/TAz96zDL

i think that i need to put the dependency in my jar file, here's my dependencies

configurations {

dependencies {
    // This dependency and its transitive deps will be embedded
    embed 'club.minnced:java-discord-rpc:2.0.1'
    compile 'club.minnced:java-discord-rpc:2.0.1'

jar {
    from configurations.embed.collect { it.isDirectory() ? it : zipTree(it) }

Sorry for my bad english, i'm french...

Edited by FrenchDxv
Link to comment
Share on other sites

Please show what you tried.

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.


As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.


For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.


Logs (Most issues require logs to diagnose):


Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.


What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...


...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension


Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.


Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.






or alternately, 


Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft


Server Not Starting:


If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.


Reporting Illegal/Inappropriate Adfocus Ads:


Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.


Posting your mod as a GitHub Repo:


When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.


  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]


Link to comment
Share on other sites

  • 1 month later...

I'm going through the same this he is, except I'm newer. Not really sure how any of this dependency stuff works but I kind of have an idea. My build.gradle doesn't have a "jar" section, so do I add it my self? Where is /META-INF? I don't understand what this maven stuff is and a have a very vague understanding of what a repository is from submitting bug reports on git. I think the .meta file is just a manifest file, and forge will use the .meta files if the jar doesn't have one. It gets the groupId:artifactId:version thing so it can be archived. What does that mean? I have the jar file that I want to use as a dependency and i looked in its META-INF folder and looked at its MANIFEST.MF file and all it said was "Manifest-Version: 1.0" Does that mean that it was a poorly made mod and what do I do about it? Do i give it a custom maven coordinate (Is that what the groupId:... thing is called?)? I'm not sure where I go from here.


Also, if  when I successfully do this dependency extraction thing, it adds the mod to minecraft but not the mods folder, correct? How to I use the mod its dependent on while making my mod? I saw that you make a folder called libs and put it in there and do some build path thing to access its code, but will that add it to the client when i run it in eclipse or do I have to add it to the run/mods folder?


I tried to put all of my questions into one post as much as possible but I'm bound to have more.

Edited by TheGoldenProof
Link to comment
Share on other sites

Make a new topic

25 minutes ago, TheGoldenProof said:

I tried to put all of my questions into one post as much as possible but I'm bound to have more.

Definitely make a new topic

About Me


My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.