Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Why is my HarvestLevel not working properly? 1.14.2


Recommended Posts

When i place a block, with this block class:

Spoiler

import net.minecraft.block.Block;
import net.minecraft.block.BlockState;
import net.minecraftforge.common.ToolType;

public class ElypsisStonePickaxeBlocks extends Block{

    public ElypsisStonePickaxeBlocks(Properties properties) {
        super(properties);
    }
       @Override
       public net.minecraftforge.common.ToolType getHarvestTool(BlockState state) {
          return ToolType.PICKAXE;
       }

       @Override
       public int getHarvestLevel(BlockState state) {
          return 3;
       }

}

i can still pick it up with a wooden pickaxe.

 

the line for my block:

Spoiler

setup(new ElypsisDiamondPickaxeBlocks(Block.Properties.create(Material.IRON).hardnessAndResistance(2.0F, 30.0F).sound(SoundType.STONE)), "amber_block"),
               

there are no warnings/errors in my log related to this.

Edited by Kaelym
forgot version.
Link to post
Share on other sites

Overriding the getHarvestLevel method and returning an Int value works for me. But then again I'm not dropping the block via a Loot Table, I spawn desired items in spawnAdditionalDrops method, and this is called when the block is harvested.

Link to post
Share on other sites

i am also having the same issue. i tried to use the spawnAdditionalDrops but it is still being called even when i use my fist. what version of forge are you both using maybe it has something to do with that. i am using forge-1.14.2-26.0.25

 

i had the idea of using json to check if you are using a diamond pick but this would get very messy when using multiple tools and tool types and it would not truly fix the problem.

 

i am going to try a few different forge versions and see if it works on an older or newer one. ill be sure to report back with any findings

Link to post
Share on other sites

I FOUND OUT WHY!!!

 

i tried to change to the newest version and the problem persisted.

 

after delving into the forge files i was able to find out that it had nothing to do with forge not working properly and had everything to do with the material type. in older versions of minecraft the material did not really mean much. now there are materials that require no tool.

 

take a look at net.minecraftforge.common.ForgeHooks if you are interested.

 

all i had to do was change my blocks Material from SAND to ROCK and everything worked as expected.

Edited by madmobhunter
swagger
Link to post
Share on other sites
2 hours ago, madmobhunter said:

in older versions of minecraft the material did not really mean much. now there are materials that require no tool.

Yeah, that's not true at all.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites
On 6/19/2019 at 7:21 AM, Draco18s said:

Yeah, that's not true at all.

im not sure what i said that is not true. maybe next time you can be more descriptive with your words.

 

i modded long ago with 1.5.2 and jumped all the way to 1.14 and so i dont know about any of the versions in between.

 

if you are talking about the materials not meaning much in older versions, in 1.5.2 the materials had no major effect on the block and were mainly used as a grouping system by mods.

 

if you are talking about the materials in 1.14 there are definitely materials that force the block to not require any tool to be harvested. as i posted before you can check it out in:

 

net.minecraftforge.common.ForgeHooks

Link to post
Share on other sites
3 hours ago, madmobhunter said:

i modded long ago with 1.5.2 and jumped all the way to 1.14 and so i dont know about any of the versions in between.

I don't remember many details back in 1.5.2, but I know for a fact that harvesting being affected by the block's material was true in 1.7.2 because I remember having this exact issue way way back then. I modded some in 1.5 and 1.6 as well, but not as much as I did in 1.7, so I'm pretty confident in my statement that materials affecting harvesting has been true for a long, long time.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.