Jump to content

Forge runClient does not actually load the mod


Recommended Posts

When running the task runClient the actual mod is not loaded even though Minecraft starts up without any errors.


I believe that these lines from the log could be part of it:

[12:32:17] [main/INFO] [FML]: -- System Details --
	Minecraft Version: 1.12.2
	Operating System: Windows 10 (amd64) version 10.0
	Java Version: 1.8.0_211, Oracle Corporation
	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
	Memory: 409724112 bytes (390 MB) / 739770368 bytes (705 MB) up to 3808428032 bytes (3632 MB)
	JVM Flags: 0 total; 
	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
	Loaded coremods (and transformers): 
LoadingPlugin (mod-0.1.jar)
	GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 419.17' Renderer: 'GeForce GTX 1080/PCIe/SSE2'
[12:32:17] [main/INFO] [FML]: MinecraftForge v14.23.1.2584 Initialized
[12:32:17] [main/INFO] [FML]: Starts to replace vanilla recipe ingredients with ore ingredients.
[12:32:18] [main/INFO] [FML]: Replaced 1036 ore ingredients
[12:32:18] [main/INFO] [FML]: Found 0 mods from the command line. Injecting into mod discoverer
[12:32:18] [main/INFO] [FML]: Searching D:\[path to project]\run\mods for mods
[12:32:19] [main/INFO] [FML]: Forge Mod Loader has identified 4 mods to load
[12:32:19] [main/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge] at CLIENT
[12:32:19] [main/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge] at SERVER


It seems to detect the mixins but not the actual mod itself.


Would really appreciate any help! I can build the client just fine, it's just some issue with my gradle configuration Im guessing.

Link to comment
Share on other sites

Please provide a GitHub repo of your mod.

Did you set up the mods.toml?

Some tips:


Modder Support:


1. Do not follow tutorials on YouTube, especially TechnoVision (previously called Loremaster) and HarryTalks, due to their promotion of bad practice and usage of outdated code.

2. Always post your code.

3. Never copy and paste code. You won't learn anything from doing that.



Programming via Eclipse's hotfixes will get you nowhere

5. Learn to use your IDE, especially the debugger.



The "picture that's worth 1000 words" only works if there's an obvious problem or a freehand red circle around it.

Support & Bug Reports:


1. Read the EAQ before asking for help. Remember to provide the appropriate log(s).

2. Versions below 1.11 are no longer supported due to their age. Update to a modern version of Minecraft to receive support.



Link to comment
Share on other sites

3 minutes ago, DavidM said:

Did you set up the mods.toml?

They are using 1.12.2


14 minutes ago, cookiedragon234 said:

When running the task runClient the actual mod is not loaded even though Minecraft starts up without any errors.

How did you setup your workspace.


I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

5 minutes ago, Animefan8888 said:

They are using 1.12.2


How did you setup your workspace.

Yep, I tried setting up a mods.toml and that didn't make any difference because I think thats for 1.14.


I don't understand what you mean by how did I setup my workspace. I imported build.gradle in IntelliJ IDEA, and ran the commands that the documentation provided to set it up.


This is my build.gradle:

buildscript {
    repositories {
        maven {
            url = "http://files.minecraftforge.net/maven"
        maven {
            name = 'SpongePowered'
            url = 'http://repo.spongepowered.org/maven'
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:2.3-SNAPSHOT'
        classpath 'org.spongepowered:mixingradle:0.4-SNAPSHOT'
apply plugin: 'net.minecraftforge.gradle.forge'
apply plugin: 'org.spongepowered.mixin'

sourceSets {
    main {
        ext.refMap = "mixins.mod.refmap.json"

jar {
            'TweakClass': 'org.spongepowered.asm.launch.MixinTweaker',
            'MixinConfigs': 'mixins.mod.json',
            'FMLCorePluginContainsFMLMod': 'true',
            'tweakClass': 'org.spongepowered.asm.launch.MixinTweaker',
            'TweakOrder': 0,
            'FMLCorePlugin': 'com.mod.mixin.LoadingPlugin',
            'ForceLoadAsMod': 'true'
//Only edit below this line, the above code adds and enables the necessary things for Forge to be setup.

version = "0.1"
group = "com.mod.mod" // http://maven.apache.org/guides/mini/guide-naming-conventions.html
archivesBaseName = "mod"

sourceCompatibility = targetCompatibility = '1.8' // Need this here so eclipse task generates correctly.
compileJava {
    sourceCompatibility = targetCompatibility = '1.8'

mixin {
    add sourceSets.main, "mixins.mod.refmap.json"

minecraft {
    version = "1.12.2-"
    runDir = "run"

    // the mappings can be changed at any time, and must be in the following format.
    // snapshot_YYYYMMDD   snapshot are built nightly.
    // stable_#            stables are built at the discretion of the MCP team.
    // Use non-default mappings at your own risk. they may not always work.
    // simply re-run your setup task after changing the mappings to update your workspace.
    mappings = 'snapshot_20180106'
    makeObfSourceJar = false // an Srg named sources jar is made by default. uncomment this to disable.

    def args = ["-Dfml.coreMods.load=com.mod.mixin.LoadingPlugin"]


repositories {
    maven {
        name = 'spongepowered-repo'
        url = 'http://repo.spongepowered.org/maven/'

    flatDir {
        dirs 'libs'

dependencies {
    // you may put jars on which you depend on in ./libs
    // or you may define them like so..
    //compile "some.group:artifact:version:classifier"
    //compile "some.group:artifact:version"

    // real examples
    //compile 'com.mod-buildcraft:buildcraft:6.0.8:dev'  // adds buildcraft to the dev env
    //compile 'com.googlecode.efficient-java-matrix-library:ejml:0.24' // adds ejml to the dev env

    // the 'provided' configuration is for optional dependencies that exist at compile-time but might not at runtime.
    //provided 'com.mod-buildcraft:buildcraft:6.0.8:dev'

    // the deobf configurations:  'deobfCompile' and 'deobfProvided' are the same as the normal compile and provided,
    // except that these dependencies get remapped to your current MCP mappings
    //deobfCompile 'com.mod-buildcraft:buildcraft:6.0.8:dev'
    //deobfProvided 'com.mod-buildcraft:buildcraft:6.0.8:dev'

    // for more info...
    // http://www.gradle.org/docs/current/userguide/artifact_dependencies_tutorial.html
    // http://www.gradle.org/docs/current/userguide/dependency_management.html

    compile("org.spongepowered:mixin:0.7.4-SNAPSHOT") {
        exclude module: 'launchwrapper'
        exclude module: 'guava'
        exclude module: 'gson'
        exclude module: 'commons-io'

    implementation files('libs/java-discord-rpc-2.0.1-all.jar')

processResources {
    // this will ensure that this task is redone when the versions change.
    inputs.property "version", project.version
    inputs.property "mcversion", project.minecraft.version

    // replace stuff in mcmod.info, nothing else
    from(sourceSets.main.resources.srcDirs) {
        include 'mcmod.info'

        // replace version and mcversion
        expand 'version': project.version, 'mcversion': project.minecraft.version

    // copy everything else except the mcmod.info
    from(sourceSets.main.resources.srcDirs) {
        exclude 'mcmod.info'


Its very confusing as it seemed to be running from the client fine last week.

Link to comment
Share on other sites

  • 2 weeks later...
On 8/17/2019 at 11:51 AM, cookiedragon234 said:

Yes actually we have, that must be why! How did you fix that?

You can re-download the mdk, rename the file before you setup the workspace and eclipse. After that you just move the src folder to the new one and you should be fine. :)

Edited by poopoodice
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.