Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

crops 1.14


Guest
 Share

Recommended Posts

Post your project as a git repository, because that's the easiest way for me to look at everything.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

  • Replies 98
  • Created
  • Last Reply

Top Posters In This Topic

Change this to final or the annotation doesn't work.

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/init/blocks/BlockInit.java#L15

 

Also, you don't need to implement IGrowable, CropsBlock already does.

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/init/blocks/plants/MPlant.java#L29

 

What is this? Why is this here? You aren't even using it anyway.

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/init/blocks/plants/MPlant.java#L40-L49

 

You are still assigning to fields directly:

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/MarijuanaCraft.java#L165

 

Why do you have both a BlockInit and a BlockList? Your BlockList is also not using annotations, also not using final, and also being assigned to directly.

 

As far as I can tell, you haven't changed anything I've asked you to change. Or if you have, you haven't updated your git repo, which makes my searching for problems completely pointless because its not your code (it is outdated).

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

1 hour ago, Draco18s said:

Change this to final or the annotation doesn't work.

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/init/blocks/BlockInit.java#L15

 

Also, you don't need to implement IGrowable, CropsBlock already does.

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/init/blocks/plants/MPlant.java#L29

 

What is this? Why is this here? You aren't even using it anyway.

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/init/blocks/plants/MPlant.java#L40-L49

 

You are still assigning to fields directly:

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/MarijuanaCraft.java#L165

 

Why do you have both a BlockInit and a BlockList? Your BlockList is also not using annotations, also not using final, and also being assigned to directly.

 

As far as I can tell, you haven't changed anything I've asked you to change. Or if you have, you haven't updated your git repo, which makes my searching for problems completely pointless because its not your code (it is outdated).

I sincerely hope this is better. but its not running now:

https://github.com/drmdgg/mcraft/tree/master/java/drmdgg/marijuanacraft/java/drmdgg/marijuanacraft

and I don't fully understand this log:

https://pastebin.com/nXAFMzkc

Link to comment
Share on other sites

Your item group is incorrect.

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/java/drmdgg/marijuanacraft/MJItemGroup.java#L7

 

You must use ModItemGroup and pass a Supplier<ItemStack> as at the point that the ItemGroup is constructed your icon item is null and vanilla code is Dumb about it.

 

Here's a working example:

https://github.com/Draco18s/ReasonableRealism/blob/1.14.4/src/main/java/com/draco18s/industry/ExpandedIndustry.java#L59

 

 

Also, your repo is not correctly set up:

https://github.com/drmdgg/mcraft

That should contain the build.gradle file, and other files at that root directory. The way you've done it has completely fucked up where your resources are.

For example, it should look like this:

https://github.com/Draco18s/ReasonableRealism

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

2 hours ago, Draco18s said:

Your item group is incorrect.

https://github.com/drmdgg/mcraft/blob/master/java/drmdgg/marijuanacraft/java/drmdgg/marijuanacraft/MJItemGroup.java#L7

 

You must use ModItemGroup and pass a Supplier<ItemStack> as at the point that the ItemGroup is constructed your icon item is null and vanilla code is Dumb about it.

 

Here's a working example:

https://github.com/Draco18s/ReasonableRealism/blob/1.14.4/src/main/java/com/draco18s/industry/ExpandedIndustry.java#L59

 

 

Also, your repo is not correctly set up:

https://github.com/drmdgg/mcraft

That should contain the build.gradle file, and other files at that root directory. The way you've done it has completely fucked up where your resources are.

For example, it should look like this:

https://github.com/Draco18s/ReasonableRealism

okay, I changed everything you told me to, but I'm still getting this:

https://pastebin.com/tRCKKfee

 

and as for the repo. that's just the repo, not my workstation

 

https://github.com/drmdgg/mcraft/tree/master/java/drmdgg/marijuanacraft

 

Edited by Guest
Link to comment
Share on other sites

1 hour ago, DrMDGG said:

and as for the repo. that's just the repo, not my workstation

Thats not how this works. Your repository must be in your project root (where the build.gradle is). The MDK comes with a .gitignore file for a reason. But you're not actually using Git, so all this is pointless. Use Git. Yes, Github != Git.

 

This makes it so nobody can actually just clone your repo and test this locally.

Link to comment
Share on other sites

1 hour ago, diesieben07 said:

Thats not how this works. Your repository must be in your project root (where the build.gradle is). The MDK comes with a .gitignore file for a reason. But you're not actually using Git, so all this is pointless. Use Git. Yes, Github != Git.

 

This makes it so nobody can actually just clone your repo and test this locally.

sorry about that. I have to run out for a while...but if it's testing you want, go to this link: 

it's the best I can offer right now.

Edited by Guest
Link to comment
Share on other sites

1 hour ago, diesieben07 said:

Thats not how this works. Your repository must be in your project root (where the build.gradle is). The MDK comes with a .gitignore file for a reason. But you're not actually using Git, so all this is pointless. Use Git. Yes, Github != Git.

 

This makes it so nobody can actually just clone your repo and test this locally.

 

33 minutes ago, diesieben07 said:

I am not downloading a random zip file of the internet.

I wouldn't want to give a virus to anyone, especially those willing to help. here is the git repo the way draco has his set up

https://github.com/drmdgg/marijuanacraft

Link to comment
Share on other sites

Great. You changed ONE thing in your ItemList to be final.

https://github.com/drmdgg/marijuanacraft/blob/master/src/main/java/drmdgg/marijuanacraft/lists/ItemList.java#L14

How about the rest of them, hmmm?

Ditto your block list:

https://github.com/drmdgg/marijuanacraft/blob/master/src/main/java/drmdgg/marijuanacraft/lists/BlockList.java#L22

 

The reason you're still getting null is because your marijuana_bud is null because @ObjectHolder only works on static final fields.

https://mcforge.readthedocs.io/en/1.13.x/concepts/registries/#injecting-registry-values-into-fields

Edited by Draco18s

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

40 minutes ago, Draco18s said:

Great. You changed ONE thing in your ItemList to be final.

https://github.com/drmdgg/marijuanacraft/blob/master/src/main/java/drmdgg/marijuanacraft/lists/ItemList.java#L14

How about the rest of them, hmmm?

Ditto your block list:

https://github.com/drmdgg/marijuanacraft/blob/master/src/main/java/drmdgg/marijuanacraft/lists/BlockList.java#L22

 

The reason you're still getting null is because your marijuana_bud is null because @ObjectHolder only works on static final fields.

https://mcforge.readthedocs.io/en/1.13.x/concepts/registries/#injecting-registry-values-into-fields

alright. I changed all the stuff to final for the ObjectHolder. https://github.com/drmdgg/marijuanacraft

 

still getting the same error

https://pastebin.com/Fu3bCQKz

Link to comment
Share on other sites

Set a breakpoint here:

https://github.com/drmdgg/marijuanacraft/blob/master/src/main/java/drmdgg/marijuanacraft/MarijuanaCraft.java#L88

Run in debug mode and inspect the value of BlockList.mplant

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

24 minutes ago, Draco18s said:

Set a breakpoint here:

https://github.com/drmdgg/marijuanacraft/blob/master/src/main/java/drmdgg/marijuanacraft/MarijuanaCraft.java#L88

Run in debug mode and inspect the value of BlockList.mplant

gradlew runclient --debug?

 

and i'm only getting the same log and crash report (besides. Minecraft won't even get to the loading screen.)

Link to comment
Share on other sites

19 minutes ago, DrMDGG said:

gradlew runclient --debug?

No debug mode in your IDE. Which one are you using?

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

1 minute ago, DrMDGG said:

eclipse

Excellent cause I don't know anything about IntelliJ. First set a breakpoint in your code by right clicking off to the left of the line you want to pause at and click "toggle breakpoint". Then up at the top next to the play button there is one that looks like a bug this is the debug run configuration thingy. Use this to run the runClient configuration.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

37 minutes ago, Animefan8888 said:

Excellent cause I don't know anything about IntelliJ. First set a breakpoint in your code by right clicking off to the left of the line you want to pause at and click "toggle breakpoint". Then up at the top next to the play button there is one that looks like a bug this is the debug run configuration thingy. Use this to run the runClient configuration.

glad to hear it!

it said that there were 2 blocks that it was unable to load. one was a mistake on my part, and the other being the block mplant. it hadn't been registered. so I added it to the registry under registerBlocks. now the game boots again. but the texture still isn't there. the block breaks like a normal crop would, but its a square, black and pink. 

now I checked through all the json files and textures and they're all there.

Link to comment
Share on other sites

Just now, DrMDGG said:

now I checked through all the json files and textures and they're all there.

Post the console output.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

8 minutes ago, DrMDGG said:

as I said, I double checked the json files against the ones for wheat, and they all check out it seems.

Yes judging by those errors it appears your block doesn't have the AGE property in it. Which doesn't make sense because it extends CropsBlock which adds the property. Try overriding fillStateContainer in your plants Block class and add your age property to the builder.

Also you can remove this. You never use it.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

2 hours ago, DrMDGG said:

eclipse

image.png.faeae6bab63f48e3380614a5f5061e3e.png

Or

image.png.f351b327cb87d7239d8ef2d310bd7b15.png

Or

F11

Or

https://lmgtfy.com/?q=eclipse+run+debug

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

9 hours ago, Animefan8888 said:

Yes judging by those errors it appears your block doesn't have the AGE property in it. Which doesn't make sense because it extends CropsBlock which adds the property. Try overriding fillStateContainer in your plants Block class and add your age property to the builder.

Also you can remove this. You never use it.

okay. I removed that section. but I am having trouble finding the fillstatecontainer in my plants block class. 

 

theres one in "Clone" for my tree, but nothing in my MPlant class unless I'm blind

what line should I place the override?

Link to comment
Share on other sites

13 minutes ago, DrMDGG said:

okay. I removed that section. but I am having trouble finding the fillstatecontainer in my plants block class. 

fillStateContainer is a method in the Block class. If you are having a hard time overriding the method you can press ctrl+space and type the method name to get suggestions.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • 1st -> https://www.curseforge.com/minecraft/mc-mods/general-disasters-1-0-1-12-2 2nd ->https://minecraftpatch.com/deadly-disasters-415551  
    • help me find in which version my mods work
    • MC Version-1.16.5-(I understand its old but the mods that are important to me haven't been updated to 1.18) Forge Version- 36.2.20 Updated all my mods and my forge version because I was having a problem with lag and now I cant even make a world because it just throws this error at me I think it might be a compatibility but I'm pretty dumb so.......   Debug-https://gist.github.com/keepinitreal247/cf97ca2dede43ce3171fd89a490f20ba
    • Hello, I am having some difficulty loading the mods I want to play with into the game. The mod is question is Litematica, (with malilib), I have downloaded both for 1.18.1 and am using the 1.18.1 Minecraft forge loader. Both mods have been moved into the mods folder but will still not show up under the Mods tab when I load up the game. Both mods have the listed type as "Executable Jar File," so I'm not sure why it isn't working. I have played with mods in different versions of the game, but have cleared them all out as they weren't ones I was using anymore, so I know it has worked before.  Some more information to note: I am trying to to load the mod into a world that I have been playing on for a bit, (solely 1.18, but I have some projects lined up here having a schematic is helpful), but I don't see that as being the reason it isn't working; I have some Vanilla tweaks resource packs loaded onto the same world; I am playing on a laptop, but it serves me well and as I said, mods have worked on it before and some larger modpacks as well, (those have been cleared off my hard drive so storage shouldn't be a problem).  I have tried everything I could think of, but it still hasn't worked: restarting and updating my laptop, signing out and back into the Minecraft launcher, downloading/installing the mods and forge in different orders, clearing out the previously used mods from the mod folder, etc.  Everything I could find online was advice for other versions, so I have no clue where to go from here.  Thank you in advance for your help.
    • Hello, I run a server on Apex and have found that every time we close out of the client and log back in, all our keys bindings are reset. It's terribly annoying. I removed mods one by one and they did not seem to cause the issue. Had tech support check the server, and nothing. It does not occur on my 1.16.5 server (run with forge). I am thinking it is a bug with the current forge. There is no error code I can see, it just resets all the keybindings. Any fixes? 
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.