Jump to content

Build failed with Exception error of setting up Workspace


Gameatro

Recommended Posts

I am starting to learn modding on Minecraft. I followed the basic steps of setting up the workspace. I downloaded the Minecraft Forge mdk zip file of the latest version. Installed JDK 8 (as 11+ are not supported). Installed latest version of gradle. I extracted the .zip file and opened powershell in that folder. But when I ran the command `gradle tasks`, as it was given in the tutorial, I am getting the following error:

Quote

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'forge-1.14.4-28.1.0-mdk'.
> Failed to notify project evaluation listener.
   > org.gradle.internal.nativeintegration.services.FileSystems.getDefault()Lorg/gradle/internal/nativeplatform/filesystem/FileSystem;

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.0.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 28s

Then when I ran the other command for decompiling the Minecraft forge files: `gradle setupDecompWorkspace` I am getting the following error:

Quote

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'forge-1.14.4-28.1.0-mdk'.
> Could not resolve all files for configuration ':_compileJava_1'.
   > Could not resolve org.ow2.asm:asm:6.2.
     Required by:
         project :
         project : > net.minecraftforge:mergetool:1.0.9
         project : > cpw.mods:modlauncher:3.2.0
         project : > net.minecraftforge:accesstransformers:1.0.0
         project : > net.minecraftforge:eventbus:1.0.0
         project : > net.minecraftforge:forgespi:1.3.0
         project : > net.minecraftforge:coremods:1.0.0
         project : > net.minecraftforge:mergetool:1.0.9 > org.ow2.asm:asm-util:6.2
      > Could not resolve org.ow2.asm:asm:6.2.
         > Could not get resource 'https://libraries.minecraft.net/org/ow2/asm/asm/6.2/asm-6.2.jar'.
            > Could not HEAD 'https://libraries.minecraft.net/org/ow2/asm/asm/6.2/asm-6.2.jar'.
               > Connect to libraries.minecraft.net:443 [libraries.minecraft.net/143.204.93.82] failed: Read timed out
   > Could not resolve org.ow2.asm:asm-commons:6.2.
     Required by:
         project :
         project : > cpw.mods:modlauncher:3.2.0
         project : > net.minecraftforge:accesstransformers:1.0.0
         project : > net.minecraftforge:eventbus:1.0.0
         project : > net.minecraftforge:forgespi:1.3.0
         project : > net.minecraftforge:coremods:1.0.0
      > Could not resolve org.ow2.asm:asm-commons:6.2.
         > Could not get resource 'https://libraries.minecraft.net/org/ow2/asm/asm-commons/6.2/asm-commons-6.2.jar'.
            > Could not HEAD 'https://libraries.minecraft.net/org/ow2/asm/asm-commons/6.2/asm-commons-6.2.jar'.
               > Connect to libraries.minecraft.net:443 [libraries.minecraft.net/143.204.93.82] failed: Read timed out
   > Could not resolve org.ow2.asm:asm-tree:6.2.
     Required by:
         project :
         project : > net.minecraftforge:mergetool:1.0.9
         project : > cpw.mods:modlauncher:3.2.0
         project : > net.minecraftforge:accesstransformers:1.0.0
         project : > net.minecraftforge:eventbus:1.0.0
         project : > net.minecraftforge:forgespi:1.3.0
         project : > net.minecraftforge:coremods:1.0.0
         project : > net.minecraftforge:mergetool:1.0.9 > org.ow2.asm:asm-util:6.2
         project : > net.minecraftforge:mergetool:1.0.9 > org.ow2.asm:asm-util:6.2 > org.ow2.asm:asm-analysis:6.2
      > Could not resolve org.ow2.asm:asm-tree:6.2.
         > Could not get resource 'https://libraries.minecraft.net/org/ow2/asm/asm-tree/6.2/asm-tree-6.2.jar'.
            > Could not HEAD 'https://libraries.minecraft.net/org/ow2/asm/asm-tree/6.2/asm-tree-6.2.jar'.
               > Connect to libraries.minecraft.net:443 [libraries.minecraft.net/143.204.93.82] failed: Read timed out
   > Could not resolve com.electronwill.night-config:core:3.6.0.
     Required by:
         project :
         project : > net.minecraftforge:forgespi:1.3.0
         project : > com.electronwill.night-config:toml:3.6.0
      > Could not resolve com.electronwill.night-config:core:3.6.0.
         > Could not get resource 'https://libraries.minecraft.net/com/electronwill/night-config/core/3.6.0/core-3.6.0.jar'.
            > Could not HEAD 'https://libraries.minecraft.net/com/electronwill/night-config/core/3.6.0/core-3.6.0.jar'.
               > Connect to libraries.minecraft.net:443 [libraries.minecraft.net/143.204.93.82] failed: Read timed out
   > Could not resolve java3d:vecmath:1.5.2.
     Required by:
         project :
      > Skipped due to earlier error
   > Could not resolve com.mojang:patchy:1.1.
     Required by:
         project : > net.minecraft:client:1.14.4
      > Skipped due to earlier error
   > Could not resolve oshi-project:oshi-core:1.1.
     Required by:
         project : > net.minecraft:client:1.14.4
      > Skipped due to earlier error
   > Could not resolve com.ibm.icu:icu4j-core-mojang:51.2.
     Required by:
         project : > net.minecraft:client:1.14.4
      > Skipped due to earlier error
   > Could not resolve com.mojang:javabridge:1.0.22.
     Required by:
         project : > net.minecraft:client:1.14.4
      > Skipped due to earlier error
   > Could not resolve com.mojang:brigadier:1.0.17.
     Required by:
         project : > net.minecraft:client:1.14.4
      > Skipped due to earlier error
   > Could not resolve com.mojang:datafixerupper:2.0.24.
     Required by:
         project : > net.minecraft:client:1.14.4
      > Skipped due to earlier error
   > Could not resolve com.mojang:authlib:1.5.25.
     Required by:
         project : > net.minecraft:client:1.14.4
      > Skipped due to earlier error
   > Could not resolve com.mojang:text2speech:1.11.3.
     Required by:
         project : > net.minecraft:client:1.14.4
      > Skipped due to earlier error

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.9/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 1m 3s

I tried online solutions like upgrading the gradle wrapper, but am still getting the error. How do I fix this error?

Link to comment
Share on other sites

7 minutes ago, Gameatro said:

You asked me the java version. that is why I told you

No, D7 did not do that:

47 minutes ago, Gameatro said:
50 minutes ago, diesieben07 said:

You can try re-installing Java.

That is the version of JDK I am using. That is the last version of the Java 8

D7 suggested reinstalling Java, it was not a question.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

32 minutes ago, Gameatro said:

He/She did in their fourth reply. well forget that, but reinstalling Java still gives the same error.

Is the minecraft libraries site down currently? I tried accessing it through different internet connections, nothing works. that may be the reason

Link to comment
Share on other sites

51 minutes ago, Gameatro said:

He/She did in their fourth reply.

A question you'd already answered and which wasn't the post you quoted. Ergo why D7 asked "How is that at all related to the message you quoted?"

It wasn't related to the post you quoted, but to a post two or three prior.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

8 hours ago, diesieben07 said:

That is not a complete URL.

Well, I tried it again and now the other exceptions are resolved. I think the site was down. But I now get:

> Could not resolve all files for configuration ':_compileJava_1'.
   > Could not find client-extra.jar (net.minecraft:client:1.15.1).
     Searched in the following locations:
         file:/C:/Users/shind/.gradle/caches/forge_gradle/bundeled_repo/net/minecraft/client/1.15.1/client-1.15.1-extra.jar

Link to comment
Share on other sites

Try deleting your gradle caches. You can do this by running gradlew clean and gradlew cleanCache. Restarting your computer can also help with uncommon problems like this.

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

  • 2 months later...

I'm also having the same problem. When I run the commands listed above, it also gives the same problem. i restarted my computer and tried again but it still gave me the same problem. What should I do?

A problem occurred configuring root project 'forge-1.15.1-30.0.50-mdk'.

> Could not resolve all files for configuration ':_compileJava_1'.

   > Could not find client-extra.jar (net.minecraft:client:1.15.1).

     Searched in the following locations:

         file:/Users/Cody/.gradle/caches/forge_gradle/bundeled_repo/net/minecraft/client/1.15.1/client-1.15.1-extra.jar

Edited by MPFighter
Link to comment
Share on other sites

1 hour ago, MPFighter said:

I'm also having the same problem.

You do not.

Please make your own thread.

Some tips:

Spoiler

Modder Support:

Spoiler

1. Do not follow tutorials on YouTube, especially TechnoVision (previously called Loremaster) and HarryTalks, due to their promotion of bad practice and usage of outdated code.

2. Always post your code.

3. Never copy and paste code. You won't learn anything from doing that.

4. 

Quote

Programming via Eclipse's hotfixes will get you nowhere

5. Learn to use your IDE, especially the debugger.

6.

Quote

The "picture that's worth 1000 words" only works if there's an obvious problem or a freehand red circle around it.

Support & Bug Reports:

Spoiler

1. Read the EAQ before asking for help. Remember to provide the appropriate log(s).

2. Versions below 1.11 are no longer supported due to their age. Update to a modern version of Minecraft to receive support.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.