Jump to content

[Solved] Can't debug client if minecraft version is set to 1.15 or above, when using 1.15/1.15.1 MDKs.


Sekwah

Recommended Posts

First of all, sorry if something isn't clear, English isn't my main language. Also i'm quite fresh new to modding and still learning Forge and Java.

I started with McJty's modding tutorials yesterday and so far i've created a block, texture, etc (basically everything shown in the video). The only differences is that i'm using Forge's 1.15.1MDK and, as logical, using that version in my mods.toml file. Everything else (mapping snapshots, forge version, etc) is up to date. Tried with 1.15MDK for a while, after failing to get it to run i switched to 1.15.1MDK and respective files and declarations.

loaderVersion is set to 30 (latest as of 1.15.1), tried with 29 (1.15, while using 1.15 client) and even 28 which is the one set by default. 
versionRange (from forge) also set to 30, also tried with the other 2.
versionRange (from minecraft) set to 1.15, 1.15.1 (tried 1.15MDK for a while, after failing to get it to run i switched to 1.15.1MDK). Even tried setting it to work from 1.15 onwards or even 1.14.4 (the one that was set by default) onwards.

In any of those cases the FML early loading process will start and finish, but when minecraft is about to launch it crashes (the code doesn't show any errors, neither does the compiler).

 

The only way i can get it to run if i set the minecraft versionRange to 1.14.4. It doesn't matter if it's 1.15, 1.15.1 or if i change the forge versions to lower ones, it only works when using minecraft 1.14.4 (haven't tried previous versions). And there isn't any file in my mod pointing to 1.14.4, in fact the only files with minecraft versions are mods.toml, and earlier mcmod.info (tried using it, along with my @Mod useMetadata value set to true as stated in documentation). There's no way to run it in 1.15.

When i run it as 1.15 or 1.15.1, but setting minecraft versionRange to 1.14.4, it loads (and obviously gives me the notification that the mod isn't created for 1.14.4).

 

Is there something i'm missing?  Some other file i should modify? Haven't been able to find any information regarding this, only older tutorials of people showing how to update a mod version (the same way i'm doing).

Sorry if this is a common question or if it's already explained somewhere else, couldn't find it.

Edit: problem is already solved! I can't believe it took me that much time lol. Always remember to check that you're using the proper variable names and to check your syntax!

Edited by Sekwah
Link to comment
Share on other sites

Do you have experience in other programming languages?

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.

 

As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.

 

For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.

Spoiler

Logs (Most issues require logs to diagnose):

Spoiler

Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.

 

What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...

 

...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension

 

Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.

 

Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

Spoiler
  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.

Video:

Spoiler

 

 

 

or alternately, 

 

Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft

 

Server Not Starting:

Spoiler

If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.

 

Reporting Illegal/Inappropriate Adfocus Ads:

Spoiler

Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.

 

Posting your mod as a GitHub Repo:

Spoiler

When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.

 

  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]

 

Link to comment
Share on other sites

40 minutes ago, DaemonUmbra said:

Do you have experience in other programming languages?

Not really. I mean i know a bit (very basic stuff) of other languages but not as in-depth as i know Java (which isn't thaaaaaat much). Why?

Edit: I'm kinda stupid and didn't noticed there were some typos when registering the block and such. Fixing those registry errors actually fixed the problem.
I was kinda lost and looking at other things because of that little detail that the game launched using 1.14.4 but not when using 1.15, now i think it's because of the order that Forge follows to load and register mods, is that correct?

Edited by Sekwah
i'm utterly stupid
Link to comment
Share on other sites

What IDE are you using and did you re-run the setup (including refreshing your gradle project & re generating your run configs) every time you changed forge version?

Here's a list of modding pre-requisites that also contains some good tutorials that I recommend.

  • Thanks 1

About Me

Spoiler

My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

3 minutes ago, Cadiboo said:

What IDE are you using and did you re-run the setup (including refreshing your gradle project & re generating your run configs) every time you changed forge version?

Here's a list of modding pre-requisites that also contains some good tutorials that I recommend.

I just solved the issue, check the edit in the comment above.

Thanks for asking tho. I did indeed re-ran the setup (build.gradle and genIntellijRuns) several times, it was just that i wasn't looking in the right places.

 

Also thanks for the link, it'll come handy later. I already know the basics about Java, OOP and the syntax (i think that's how it's called in English?), it's just that i don't have much experience and i'm also new to Intellij (was using NetBeans previously), but the other in-depth forge information will be really useful!. 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.