Jump to content

[1.15.2] NoSuchMethodError when testing on server


PianoManu

Recommended Posts

Hey guys!

I ran into some obstinate NoSuchMethodError today whilst testing my mod on a server (locally). I made a block with a tile entity, that mimics another block when it's right-clicked with said block. When I break the block containing the other block, my method "dropContainedBlock" is called to spawn an ItemEntity of the mimicked block. Now that is where I get the NoSuchMethodError exception and the server crashes. Here's my method. I mainly copied it from the vanilla jukebox, but the jukebox works a bit different because it "stores" only records, not blocks:

    //Used to drop the contained block
    //We check the tile entity, get the block from the tile entity and drop it at the block pos plus some small random coords in the world
    protected void dropContainedBlock(World worldIn, BlockPos pos) {
        if (!worldIn.isRemote) {
            TileEntity tileentity = worldIn.getTileEntity(pos);
            if (tileentity instanceof FrameBlockTile) {
                FrameBlockTile frameTileEntity = (FrameBlockTile) tileentity; //My custom tile entity
                BlockState blockState = frameTileEntity.getMimic(); //the contained blockstate
                if (!(blockState == null)) {
                    worldIn.playEvent(1010, pos, 0);
                    //some coords to spawn the item entity
                    double d0 = (double) (worldIn.rand.nextFloat() * 0.7F) + (double) 0.15F;
                    double d1 = (double) (worldIn.rand.nextFloat() * 0.7F) + (double) 0.060000002F + 0.6D;
                    double d2 = (double) (worldIn.rand.nextFloat() * 0.7F) + (double) 0.15F;
                    ItemStack itemstack1 = blockState.getBlock().asItem().getDefaultInstance(); //<---- THAT IS WHERE I GET THE ERROR
                    ItemEntity itementity = new ItemEntity(worldIn, (double) pos.getX() + d0, (double) pos.getY() + d1, (double) pos.getZ() + d2, itemstack1);
                    itementity.setDefaultPickupDelay();
                    worldIn.addEntity(itementity); //this should spawn the item entity - works fine in singleplayer but not on servers
                    frameTileEntity.clear(); //resets my tile entity
                }
            }
        }
    }

It works fine in singleplayer, but when I tried it on a local server, it crashes. I get the following error: "java.lang.NoSuchMethodError: net.minecraft.item.Item.func_190903_i()Lnet/minecraft/item/ItemStack;". This "func_190903_i()" has to be the "getDefaultInstance()"-method, it is annotated as @OnlyIn(Dist.CLIENT) and I guess that's the reason why it does not work on servers. Now my question: How do I get it to work on servers?

Sorry if this is dumb, I'm pretty new and inexperienced...

Regards, Manu

 

In case you need the complete crash report: https://pastebin.com/hAa3Mcfz

Link to comment
Share on other sites

Why you use this to get and itemStack?

ItemStack itemstack1 = blockState.getBlock().asItem().getDefaultInstance(); //<---- THAT IS WHERE I GET THE ERROR
                    

I think you just need to create an ItemStack with new ItemStack(blockstate.getBlock().asItem())

  • Thanks 1

Check out the port of the BetterEnd fabric mod (WIP): https://www.curseforge.com/minecraft/mc-mods/betterend-forge-port

Link to comment
Share on other sites

I'm pretty sure new ItemStack(blockstate.getBlock()) is sufficient. Last I checked, the ItemStack class has a constructor that will do the block -> item conversion for you.

  • Thanks 1

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.