Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Support & Bug Reports

Help with Forge goes here. Refer to Modder Support for help with Forge modding. You MUST read the EAQ before posting.


23233 topics in this forum

    • 24 replies
    • 3.9k views
    • 24 replies
    • 71.4k views
    • 24 replies
    • 500 views
    • 24 replies
    • 880 views
    • 24 replies
    • 718 views
  1. forge no me funciona

    • 24 replies
    • 1.4k views
    • 24 replies
    • 4.9k views
  2. Q-tech cant play

    • 23 replies
    • 353 views
  3. 1.16.X Launch problem

    • 23 replies
    • 1.1k views
    • 23 replies
    • 582 views
    • 23 replies
    • 582 views
  4. Lenovo Forge

    • 23 replies
    • 4.9k views
    • 23 replies
    • 1.7k views
    • 23 replies
    • 25.4k views
    • 23 replies
    • 55.3k views
  5. Forge 1 error

    • 23 replies
    • 13.2k views
    • 23 replies
    • 2.2k views
    • 23 replies
    • 2k views
  6. Forge "Not Updated"

    • 23 replies
    • 1.3k views
    • 23 replies
    • 32.9k views
    • 23 replies
    • 276.8k views
    • 23 replies
    • 2k views
  7. Forge library locations?

    • 23 replies
    • 4.2k views
    • 23 replies
    • 44.2k views
    • 23 replies
    • 655 views


  • Posts

    • Now your code does not work in single player. What even?
    • Neither of those is a complete debug.log. Please use a spoiler or https://gist.github.com/ to post large text files.
    • That could be any number of things. Please post the debug.log as well as your JVM arguments.
    • That is an old log, please post the debug.log.
    • Hi! I've been having a really frustrating problem with registering my projectile to my Entity Type registry.   As you can see, my Entity Type class cannot resolve my projectile's constructor due to having more than one constructors sharing the same name. When I press Create constructor, it will create this: However, the constructor does not work as when I put in entityEntityType and world into the super this will happen: And when I change the EntityType from Entity to an extension, it would simply results in a copy of the first constructor of my entity resulting in a loop where my projectile would simply be unable to be added into my Entity Type registry.🥴 Now, the obvious problem would be that there are more than one constructors sharing the same name, so one should either change the names of the other constructors or remove them. Not so fast buckeroo 👈👈 🤠, those constructors help make the projectile move like a projectile in the first place (Moving from one position to another without simply appearing at the other position). What's really frustrating about this, is that most of the game's projectiles are codded no differently than my own, with multiple constructors sharing the same name, one for registering, the others for the projectile to actually shoot from their original position, and are registered properly. Heck, my projectile is actually a Ghast Fireball that can't be punched nor break blocks!  Now I am in a dilemma. As you can tell, I'm new to Modding Minecraft as my Entity Type registry is based/copied from Technovision's tutorial(https://www.youtube.com/watch?v=zJkQc2A1PIk&list=PLDhiRTZ_vnoWsCqtoG1X1MbGY5xATTadb&index=18) and I really want to create my own custom projectiles rather than using Minecraft's already existing projectile.  I even tried to revamp my EntityType Registry to be similar to Minecraft, but it still has the same problem, can't resolve constructor, new having the dreaded red squiggly line and all. Thank you for reading about my problem! Please, tell me how I can fix this or what I can do! 😊    
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.