Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Will there be a 1.7.4/1.7.8 release?


michael2mandy
 Share

Recommended Posts

  • 2 weeks later...
  • 2 weeks later...

Hi everyone. My 8 year old son lives to play Minecraft but I do the maintenance for him. This 1.7.2 vs 1.7.4 stuff has left me very confused. Maybe it is clear to all of you - but not to me. He plays Minecraft 1.7.4 and I am trying to install the Rival Rebels mod for him. I understand that I need to install Minecraft Forge first, and that there isn't a version yet for 1.7.4. But I don't understand if I can install the 1.7.2 version of Minecraft Forge to run with Minecraft 1.7.4 or if he needs to play the 1.7.2 version of Minecraft to get it to work. Also, is there a 1.7.2 version of Rival Rebels or do we actually need an older version of everything for that? Thanks in advance for your help.

Link to comment
Share on other sites

Since I failed to find reliable information I have to ask and

 

it seems appropriate to ask my question here.

 

I know that it depends on various circumstances but ...

 

How far has the 1.7.4 forge development come?

 

Has the project which forge is depending on ... the decrypting one (dunno how to describe it better) ... started to work on 1.7.4?

... and if ... how far are they? just begun? halfway through? done? (failed to find the infos, and I know you can't start without)

 

 

 

 

Link to comment
Share on other sites

Nobody cares about 1.7.4 on the modding end.

We will not be updating to 1.7.4 untill we get a large mod base for 1.7.2 up and going.

And by that time we will probably just jump ahead to 1.7.6/1.7.7 whatever they have out.

The 1.7.2->1.7.x updates should be trivial compared to the 1.6.4->1.7.2 update, so we're letting modders tackle that before we even think about updating.

Seriously, how many times do I have to answer this question?

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Seriously, how many times do I have to answer this question?

 

Six thousand nine hundred and fifty two.

 

Over in the Mystcraft thread on the Minecraft forums we had an account for posting answers to common questions at the top of each page and the mods told us to stop.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

  • 1 month later...

Hoping someone can help out this Mom who can't manage to get it right!  I buy Nintendo DS not the 3D version, and all of the good games are only available in 3D.  Kiddo gets her All-A marking period reward of the latest & greatest version of Minecraft (1.7.9), and the only versions available to run on the darn thing are 1.7.5, 1.7.7, 1.7.8 and 1.7.9.  Now she desperately wants to install mods, and I can't for the life of me figure out how to download a compatible version of Forge!  Is there a way to download an earlier version of Minecraft?  I just checked the Minecraft.net site, and wasn't finding anything.  Do I just have to tell her this is going to be a few months of waiting?  Any advice?  Thanks very much!!

Link to comment
Share on other sites

Hoping someone can help out this Mom who can't manage to get it right!  I buy Nintendo DS not the 3D version, and all of the good games are only available in 3D.  Kiddo gets her All-A marking period reward of the latest & greatest version of Minecraft (1.7.9), and the only versions available to run on the darn thing are 1.7.5, 1.7.7, 1.7.8 and 1.7.9.  Now she desperately wants to install mods, and I can't for the life of me figure out how to download a compatible version of Forge!  Is there a way to download an earlier version of Minecraft?  I just checked the Minecraft.net site, and wasn't finding anything.  Do I just have to tell her this is going to be a few months of waiting?  Any advice?  Thanks very much!!

In the lower left corner of the launch screen are new profile and edit profile buttons.  Click on either one and in the middle of that is the Version Selection with a dropbox list of previous minecraft versions next to the text Use Version.  Select 1.7.2 to use with the 1.7.2 version of forge and forge mods.  Another common version to use is 1.6.4 since many more mods are available with that version.  This is also shown real quick about 20 seconds into this Youtube video

Link to comment
Share on other sites

 

In the lower left corner of the launch screen are new profile and edit profile buttons.  Click on either one and in the middle of that is the Version Selection with a dropbox list of previous minecraft versions next to the text Use Version.  Select 1.7.2 to use with the 1.7.2 version of forge and forge mods.  Another common version to use is 1.6.4 since many more mods are available with that version.  This is also shown real quick about 20 seconds into this Youtube video

Thanks so much.  Not sure how I missed that!  Now I just need to figure out what I did wrong in downloading RADIXCORE, and hopefully I'll be in business.  Who knew how many hours I would need to spend on this reward...maybe I won't care about a B in Math so much next time!  Thanks again.

Link to comment
Share on other sites

We will not be updating to 1.7.4 untill we get a large mod base for 1.7.2 up and going.

Well, there are currently 292 mods for minecraft 1.7.2 and the most of them are forge mods. (about 90% or 95%)

From my mod I have currently rewritten 20.97% to Minecraft Forge 1.7.2 (well 20.97% from version Alpha 0.0.9)

Developer of Primeval Forest.

Link to comment
Share on other sites

Yes, it's getting about that time to do another update. There are a few things that need to be settled first. And I need to find time to do it with my personal life {really really busy} But yes I am looking into finalizing the 1.7.2 branch and updating to 1.7.9.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Yes, it's getting about that time to do another update. There are a few things that need to be settled first. And I need to find time to do it with my personal life {really really busy} But yes I am looking into finalizing the 1.7.2 branch and updating to 1.7.9.

 

That is one really good news !

I hope that your personal life busy part isn't something bad for you, and good luck for the 1.7.9 update.

Is the new UUID system complex, or does it just changes from username to UUID ?

 

( Sorry if it doesn't make any sense in a grammatical way or something like that, English is not my main language )

Link to comment
Share on other sites

  • 2 weeks later...

Nobody cares about 1.7.4 on the modding end.

We will not be updating to 1.7.4 untill we get a large mod base for 1.7.2 up and going.

And by that time we will probably just jump ahead to 1.7.6/1.7.7 whatever they have out.

The 1.7.2->1.7.x updates should be trivial compared to the 1.6.4->1.7.2 update, so we're letting modders tackle that before we even think about updating.

Seriously, how many times do I have to answer this question?

 

First and foremost: Thanks for all the work you do on this and taking the time to answer posters' questions about when updates are coming and how to get forge working when it doesn't work.  I've personally benefited a lot from your posts on those subjects.

 

One reason that I am personally a little antsy to see the forge move onto versions beyond 1.7.2 is that one of my favorite mods (Tinker's construct) has stated that it won't be officially supported until forge moves past 1.7.2.  I'm not sure why mDiyo has decided to leave TiC in an alpha state for 1.7.2, but I look forward to new toys when it happens.

 

I understand that no one in the mod community really cares about the twitch functionality added in 1.7.4, but some modders are waiting for for forge to move beyond 1.7.2 before releasing more content it seems.  Also, I saw your post above that you'r looking to finalize 1.7.2 and move on, so that's more good news!  Thanks again for you work!

Link to comment
Share on other sites

  • 2 weeks later...

It'll be updated to eventually, as stated before there is nothing of use to modders in the update. And with the instability of Mojang's releases we're waiting till they calm down a bit.

However as cpw said we do have internal build of 1.7.9 ready to go. There are a few things we are waiting on before releasing such as a re-work of MCP's mapping database to support snapshots.

 

I will say, I have actually confirmed, the update between 1.7.2 and 1.7.9 is SUPER small for Modders.

So encourage as many modders as you can to update to 1.7.2 it'll make all future update really easy.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.