Jump to content

Forge broke Optifine 1.18.2...


Recommended Posts

So gona make this quick, newer forge versions on 1.18.2 broke optifine somehow... some newer versions just crash when creating or loading into world or straigh up breaks the game itself with optifine, and you cant damage ender dragon with melee with is absurd...

even with mods and optifine you cant damage some enemys on those newer versions of forge, even modded, for example wither storm mod tenticles...

but strangely older versions of optifine work they broke somewhere past 40.1.0 forge version...

can anyone of the forge support look into it??? there few reports as well like here: 

 

its really frustrating playing with older forge cause many mods break or arent compatable

Link to comment
Share on other sites

Are you sure the Optifine version you are using is compatible with the Forge version you are using?
if yes which exact Optifine and Forge version are you using?

5 minutes ago, gintasjonelis said:

even with mods and optifine you cant damage some enemys on those newer versions of forge, even modded, for example wither storm mod tenticles...

This should not be related to Optifine, since Optifine is a client side render Mod as far as i know they do not modify the client key and mouse input,
and entities are damaged server side only.

Please post debug.log from the logs folder.

Link to comment
Share on other sites

Optifine works with specific versions of forge, they show which ones on the download page.

Just like any other mod author, if forge makes changes, then the mod (in this case optifine) will potentially need updating. This should be brought to the optifine developer

Link to comment
Share on other sites

3 minutes ago, Luis_ST said:

Are you sure the Optifine version you are using is compatible with the Forge version you are using?
if yes which exact Optifine and Forge version are you using?

This should not be related to Optifine, since Optifine is a client side render Mod as far as i know they do not modify the client key and mouse input,
and entities are damaged server side only.

Please post debug.log from the logs folder.

Like i said when using 40.1.0 everything works fine (with optifine) but other mods like baubley-heart-canisters-1.18.2-1.0.0 kinda breaks with hearth colors and stacks like vanilla instead of color stacking... but im using atm optifine that works: 40.1.57 past this version optifine completly dosent work anymore, because it crashes when creating or loading world...

here is that debug.log file idk how it will help tho: https://pastebin.pl/view/36151117

 

Link to comment
Share on other sites

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

To be clear, Optifine is a closed source major CoreMod. It is on them to be compatible with us, not the other way around. 
We constantly make changes that are required to improve Forge/Minecraft. There isn't anything we can do to know how it will interact with Optifine.
So, your best bet is to NOT use Optifine, but if you must, use the EXACT version of Forge it says it is compatible with.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

21 minutes ago, LexManos said:

To be clear, Optifine is a closed source major CoreMod. It is on them to be compatible with us, not the other way around. 
We constantly make changes that are required to improve Forge/Minecraft. There isn't anything we can do to know how it will interact with Optifine.
So, your best bet is to NOT use Optifine, but if you must, use the EXACT version of Forge it says it is compatible with.

well what i found are other mods like sodium port to forge from fabric works great with dynamic lighting mod, well i guess have to deal with it

Link to comment
Share on other sites

4 minutes ago, gintasjonelis said:

well what i found are other mods like sodium port to forge from fabric works great with dynamic lighting mod, well i guess have to deal with it

I would not recommend you to use Mods like Sodium, since the most magic performance Mods increase the game performance due breaking of game mechanics.
This can cause problems with other Mods

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.