Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Introduction and New Server for Forums!


Guest Mr. Flamegoat

Recommended Posts

Guest Mr. Flamegoat

Howdy, all!

 

Quick intro: my name is MrFlamegoat aka Matt. Some of you know me, many of you won't and that's okay. I'm stepping in to help out with the forums a bit more.

 

Firstly, we've moved the forums to a new server and there were a few hiccups along the way. Everything seems to be in order now though, and hopefully everything is moving quickly for everyone.

 

Secondly, if you notice anything out of place, broken, or that just seems wonky PLEASE POST HERE. I'd love to know and I'll be working over the next couple of weeks to update, polish, clean, and optimize.

 

I think that's it. Hopefully this move didn't affect anyone too negatively.

 

Look forward to the feedback, thanks everyone!

 

Update: Email Issues Resolved!

We're now utilizing a 3rd party MTA (sparkpost) to handle all outbound emails from the forums. This should be much more reliable than default PHP methods, as well as being faster and validated. Emails should make it to your inboxes more often while avoiding the doom and gloom of the Spam folder.

 

Emails will now appear as forums@minecraftforge[dot]net via a sparkpost hostname.  Apologies to anyone that had the previous address filtered!

 

Update: Code Highlighter

Added a code highlighter that I can modify and change. It should be forward compatible (I'm removing things that are not, as well as anything that changes core files to an unpatchable state).

 

Let me know what you guys think about it.

 

Update: Forums upgraded and theme has been updated a bit.

I've patched the forums to the latest available (2.0.11) and made some rather large changes to the current theme to bring it a little closer to the modern age. It's still a long way from where I'd like it, but hopefully everything feels a bit more professional.

 

I've removed a few things (team page, various little bits) until I can update them to all fit coherently together. If you guys have any thoughts or opinions on the style and direction, please let me know!

 

If you just don't really care, that's fine too! :D

 

Update: Code Highlighting mostly fixed!

Automatic detection of language is not terribly easy - sometimes your code snippet may default to a language other than Java. If that happens, you can specify from changing the code tag from "code" to "code=java" or other supported language.

 

I've added gradle/groovy as supported languages and can add others as required.

Link to post
Share on other sites
Guest Mr. Flamegoat

It should get quite a bit faster, too! Well, technically speaking. Might not notice it - but I'm doing my best.

 

We should be updating to the latest SMF in the next day or two. That should help quite a bit with some of the few hiccups left that I haven't been able to work out.

 

Feel free to yell in my general direction if anything is out of place, missing, or broken :D

Link to post
Share on other sites
Guest Mr. Flamegoat

I was actually afraid people would get mad. It's not perfect, but it's the best I can offer at the moment. :D

 

I'm having to move modules around and get it prepared for the upgrade :D It's forward compatible, so it's on the list!

Link to post
Share on other sites

Liking the new changes so far! (Especially the code syntax highlighting!)

Colore - The mod that adds monochrome blocks in every color of the rainbow!

http://www.minecraftforge.net/forum/index.php?topic=35149

 

If you're looking to learn how to make mods for 1.9.4, I wrote a helpful article with links to a lot of useful resources for learning Minecraft 1.9.4 modding!

 

http://supergeniuszeb.com/mods/a-helpful-list-of-minecraft-1-9-4-modding-resources/

Link to post
Share on other sites
Guest Mr. Flamegoat

There's a slight bug with the syntax highlighter:

 

// Tools (After Enum it's; Harvest Level, Durability/Uses

 

The highlighter thinks everything after the ' is in a string, but it's not because the line is commented.

 

Yea I've got some work to do on the highlighter. Some of the themes don't have appropriate language syntax. Will update soon!

Link to post
Share on other sites

If you post a log here in the forums the editor begins to lag after you pasted it in.

I don't know how long the log needs to be to let the editor lag, but I had the problems with a 500 lines log in a spoiler.

 

Besides that, nice forum update. :)

Finally something better then before with this forum. For me the old one had really long loading times compared to other websites...

Keep up the good work. ;)

Developer of Primeval Forest.

Link to post
Share on other sites
Guest Mr. Flamegoat

The Wiki button at files.minecraftforge.net is leading to 404 page (obviously because it is keeping the files. at the begining), I would suggest to fix it.

 

Hrm, I don't have access to files currently - but I will definitely pass that along!

 

If you post a log here in the forums the editor begins to lag after you pasted it in.

I don't know how long the log needs to be to let the editor lag, but I had the problems with a 500 lines log in a spoiler.

 

Besides that, nice forum update. :)

Finally something better then before with this forum. For me the old one had really long loading times compared to other websites...

Keep up the good work. ;)

 

I will look into this ASAP. Not sure how much JS is running to process the text box at the moment, but it's probably due to that. I'll see if there's anything I can fix or improve!

Link to post
Share on other sites

Found a bug (not sure if it was there before or not):

 

When typing a post, if you try to expand the editor box by dragging the double-lined bar at the bottom, it won't work. The double-diagonal line in the corner does work, however. Not really that big of an issue, but I thought I'd let you know anyway.

Colore - The mod that adds monochrome blocks in every color of the rainbow!

http://www.minecraftforge.net/forum/index.php?topic=35149

 

If you're looking to learn how to make mods for 1.9.4, I wrote a helpful article with links to a lot of useful resources for learning Minecraft 1.9.4 modding!

 

http://supergeniuszeb.com/mods/a-helpful-list-of-minecraft-1-9-4-modding-resources/

Link to post
Share on other sites
Guest Mr. Flamegoat

Found a bug (not sure if it was there before or not):

 

When typing a post, if you try to expand the editor box by dragging the double-lined bar at the bottom, it won't work. The double-diagonal line in the corner does work, however. Not really that big of an issue, but I thought I'd let you know anyway.

 

Released another major update to the theme. Tried to figure this one out but it appears it's been around a while.

 

No fix available at the moment without digging into the SMF editor and well, it's not good lol. :D

 

Might see if I can just hide it, that way at least it's not a visible broken feature.

Link to post
Share on other sites

The "new" markers on the individual forum pages are broken. It seems like if there is at least one "new" thread, all of them have the marker.+

 

Edit: No, it's not that...But they do behave a bit weirdly as a bunch of old threads I have definitely read are marked as "new".

Link to post
Share on other sites

The "new" markers on the individual forum pages are broken. It seems like if there is at least one "new" thread, all of them have the marker.

I think it is. I just read a few threads in Modder Support, and when one of them got a new reply, every thread showed the "new" label. When I read the new reply, went back to Modder Support and refreshed the page, the "new" markers dissappeared.

 

EDIT: If you click the "new" button on a post without a new reply, it goes to another thread which does have a new reply.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to post
Share on other sites

As they say: fix a bug, now you have 99 more :v

The only thing that I found (which may be on my side only, cause I have shit pc and internet), is that when you click the + to expand at Forum History (at the Statistics Center), the Loading that pops up on the top, sometimes, flicks a lot, and may cause problems to people who suffer from epilepsy.

Creating Potatium Craft, please wait.

For a better (and yet poor explanation of my WIP mod, go to: Potatium Craft Overview )

Link to post
Share on other sites

The "new" markers on the individual forum pages are broken. It seems like if there is at least one "new" thread, all of them have the marker.

I think it is. I just read a few threads in Modder Support, and when one of them got a new reply, every thread showed the "new" label. When I read the new reply, went back to Modder Support and refreshed the page, the "new" markers dissappeared.

 

EDIT: If you click the "new" button on a post without a new reply, it goes to another thread which does have a new reply.

 

This is annoying the fuck out of me.

As soon as I noticed it my immediate thought was, "What'd we do downgrade our forum software?"

 

new.png

 

But Larsgerrits is correct, the new button doesn't even apply to the thread it's next to:

 

busted.png

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites
Guest Mr. Flamegoat

The "new" markers on the individual forum pages are broken. It seems like if there is at least one "new" thread, all of them have the marker.

I think it is. I just read a few threads in Modder Support, and when one of them got a new reply, every thread showed the "new" label. When I read the new reply, went back to Modder Support and refreshed the page, the "new" markers dissappeared.

 

EDIT: If you click the "new" button on a post without a new reply, it goes to another thread which does have a new reply.

 

Got that fixed up. This forum software was written back in 2006, so the bulk of it is very difficult to wade through. It wasn't great when it was written, but by today's standards it's atrocious.

 

I've fixed more than 300 issues so far that consisted of mostly poor performance issues with a heavy peppering of security holes and issues.

 

The load time on server has been reduced from 0.280ms average (with several second spikes) to an average of 0.03ms. So hopefully that's noticeable and helpful to you guys.

 

Trying my best to test thoroughly, as I've finally got it to a point I can work on it offline and push updates appropriately.

 

Sorry for any issues that causes anyone, though. Please continue to let me know any issues that arise.

 

As they say: fix a bug, now you have 99 more :v

The only thing that I found (which may be on my side only, cause I have shit pc and internet), is that when you click the + to expand at Forum History (at the Statistics Center), the Loading that pops up on the top, sometimes, flicks a lot, and may cause problems to people who suffer from epilepsy.

 

Hrm, I haven't seen this just yet, but I'll keep testing and see if I can fix this up.

Link to post
Share on other sites
The load time on server has been reduced from 0.280ms average (with several second spikes) to an average of 0.03ms. So hopefully that's noticeable and helpful to you guys.

Hell yeah is it ever noticeable. This is the best part of the change by far!
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • You sort of wrote yourself into a corner there..... But, truthfully, 1.7 is no longer supported due to being so old, only the current (1.16.x) and previous (1.15.x) versions are supported. You will need to update to a modern version to receive support.
    • Alright so I don't really understand all the files and technical stuff so please don't answer with that. I saw a forum with the same problem where 1.7 wasn't working for him. He said that he manually installed forge and that worked. what does that mean and how do I do that?
    • I have done that, but I still cannot find a "EntityAttributeCreationEvent" event class or method anywhere when using intellij's search feature. Also when I try to run, I now get an error: BlocksReal's Block Creatures\build\tmp\expandedArchives\forge-1.16.5-36.1.6_mapped_snapshot_20210421-1.15.1-sources.jar_a6143e0dca70b177e5cb22179a0cd7b2\net\minecraft\entity\EntityClassification.java:40: error: method getName() is already defined in enum EntityClassification public String getName() {  
    • Hello! Wanted to make a server, and when i launched the server with all of the mods its just crashing with "io.netty.channel.abstractchannel$annotatedconnectexception connection refused no further information:" Can someone tell me what to do in order to fix it?         Server log: Starting Gameserver now... [18:44:48] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.1.6, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui] [18:44:48] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 1.8.0_272 by Red Hat, Inc. [18:44:49] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.onLoad [18:44:49] [main/INFO] [op.OptiFineTransformationService/]: OptiFine ZIP file: /mnt/minecraftotherpacks/mods/OptiFine_1.16.5_HD_U_G7_MOD.jar [18:44:49] [main/INFO] [op.OptiFineTransformer/]: Target.PRE_CLASS is available [18:44:49] [main/INFO] [ne.mi.fm.lo.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust [18:44:49] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.2 Source=file:/mnt/minecraftotherpacks/libraries/org/spongepowered/mixin/0.8.2/mixin-0.8.2.jar Service=ModLauncher Env=SERVER [18:44:49] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.initialize [18:44:50] [main/INFO] [STDERR/]: [org.antlr.v4.runtime.ConsoleErrorListener:syntaxError:38]: line 1:0 token recognition error at: '~' [18:44:50] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.transformers [18:44:50] [main/INFO] [op.OptiFineTransformer/]: Targets: 308 [18:44:50] [main/INFO] [op.OptiFineTransformationService/]: additionalClassesLocator: [optifine., net.optifine.] [18:44:51] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [com.qouteall.hiding_in_the_bushes.MyMixinConnector] [18:44:51] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [tictim.paraglider.MixinConnector] [18:44:51] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [midnight.core.MixinConnector] [18:44:51] [main/INFO] [Portal/]: Invoking Mixin Connector [18:44:51] [main/ERROR] [mixin/]: Mixin config imm_ptl_mixins.json does not specify "minVersion" property [18:44:51] [main/ERROR] [mixin/]: Mixin config imm_ptl_mixins_forge.json does not specify "minVersion" property [18:44:51] [main/ERROR] [mixin/]: Mixin config imm_ptl_peripheral_mixins.json does not specify "minVersion" property [18:44:51] [main/INFO] [cp.mo.mo.LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmlserver' with arguments [--gameDir, ., nogui] [18:44:52] [main/WARN] [mixin/]: @Mixin target net/minecraft/world/server/ChunkManager$EntityTracker is public in imm_ptl_mixins.json:common.entity_sync.MixinEntityTracker and should be specified in value [18:44:52] [main/FATAL] [ne.mi.fm.lo.RuntimeDistCleaner/DISTXFORM]: Attempted to load class net/minecraft/client/gui/screen/Screen for invalid dist DEDICATED_SERVER Exception in thread "main" [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:39) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.Launcher.run(Launcher.java:82) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: Caused by: java.lang.reflect.InvocationTargetException [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at java.lang.reflect.Method.invoke(Method.java:498) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at net.minecraftforge.fml.loading.FMLServerLaunchProvider.lambda$launchService$0(FMLServerLaunchProvider.java:51) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: ... 7 more [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: Caused by: java.lang.ExceptionInInitializerError [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: at net.minecraft.crash.CrashReport.func_71504_g(CrashReport.java:101) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: at net.minecraft.crash.CrashReport.<init>(CrashReport.java:54) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: at net.minecraft.crash.CrashReport.func_230188_h_(CrashReport.java:425) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: at net.minecraft.server.Main.main(Main.java:91) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: ... 13 more [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: Caused by: java.lang.RuntimeException: Attempted to load class net/minecraft/client/gui/screen/Screen for invalid dist DEDICATED_SERVER [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at net.minecraftforge.fml.loading.RuntimeDistCleaner.processClassWithFlags(RuntimeDistCleaner.java:71) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.LaunchPluginHandler.offerClassNodeToPlugins(LaunchPluginHandler.java:85) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.ClassTransformer.transform(ClassTransformer.java:120) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.TransformingClassLoader$DelegatedClassLoader.findClass(TransformingClassLoader.java:265) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:136) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:98) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at java.lang.ClassLoader.loadClass(ClassLoader.java:351) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at net.optifine.reflect.Reflector.<clinit>(Reflector.java:185) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: ... 17 more Gameserver exited without success - 1 Exiting now...     "[18:51:30] [main/FATAL] [ne.mi.fm.lo.RuntimeDistCleaner/DISTXFORM]: Attempted to load class net/minecraft/client/gui/screen/Screen for invalid dist DEDICATED_SERVER" I think this one might be the Error, but I dont know how to fix that  
    • I can't. This computer doesn't support windows any higher. And. I don't like Linux. Just with no reason. Idc about the security, cuz my browser just stops me from connecting to unsafe websites, so i don't have to be afraid of getting a virus from the internet. Even if i got something, i can just dowload free version of Dr Web and scan the computer.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.