Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

keepcalm

Forge Modder
  • Posts

    281
  • Joined

  • Last visited

Everything posted by keepcalm

  1. extract mcp. copy .minecraft/bin into jars folder. copy .minecraft/resources into jars folder. Download minecraft_server.jar (https://s3.amazonaws.com/MinecraftDownload/launcher/minecraft_server.jar), copy into jars folder. extract forge into mcp folder. go into forge folder, run install.cmd.
  2. Is this what you're looking for? When you're looking for events it helps to look in the sub-packages of net.minecraftforge.event
  3. http://adf.ly/673885/http://files.minecraftforge.net/minecraftforge-universal-4.1.4.298.zip
  4. As a guess, I'd say you somehow messed up your optifine installation - the error is graphics-related on the clientside, so probably try an older or newer version of optifine, and check the optifine thread on minecraftforum to see if there's anything there about forge versions.
  5. Did you copy the WHOLE bin directory into jars?? Your LWJGL natives are missing. They should be in <mcp folder>/jars/bin/natives
  6. Go and find a tutorial (like Wuppy29's), and all will become clear.
  7. new EntityItem(World world, double x, double y, double z, ItemStack stack) Protip: it helps to actually look on the javadocs/Internet before asking on the forum
  8. Try reinstalling MCP and forge - backup your eclipse files (if you have any), and delete the mcp folder, start from scratch...
  9. If you absolutely MUST export it into the mods folder, export into <mcp folder>/jars/mods/x.jar The crash you're seeing is because you need to reobfuscate everything in mcp. You need to copy your packages into the common folder in the Minecraft project in eclipse. Then, open up your mcp folder and run recompile.sh/.bat and then reobfuscate.sh/bat But seriously, it's far easier to just code it all in the Minecraft project.
  10. I want to reset the CraftingManager - I have an access transformer, which transforms everything i need to public, but I can't work out how to remove the final part from the declaration through the access transformer.
  11. So you'd have a method, for instance: public void triggerNote(World world, int x, int y, int z, byte instrument)
  12. You're setting MT_mod's instance to an instance of MF_mod.
  13. I tried this just a few minutes ago, and it went smoothly until it came time to repackage the Forgified MC_server.jar. I can't seem to compress the mctmp back into the MC_server.jar. I tried a few times now with some mixed results, once or twice it would return with the "Invalid or Corrupt" line from before. However it did come back with so I guess that is a small step forward, right? Lol yeah this time it looks like your FML is corrupted somehow - it's not getting any version numbers, so it's looking for minecraft version 'missing', but finds version '1.3.2', and then blows up. So try redownloading forge? Try using the latest recommended, and the latest latest...
  14. Wouldn't generating it be pretty similar to adding an ore block? You just have to check that the block below it is grass and can see the sun, and then run, say GenCustomTree(blockX, blockY, blockZ)? You could always look at the vanilla WorldGenTrees code...
  15. I've written a coremod which just changes the accessibility of some fields using access transformers, but for some reason when I start it up, I get errors complaining that some events don't exist. The log The access transformer .cfg file
  16. Assuming your minecraft_server.jar is in /Users/yourusername/server/minecraft_server.jar, and forge is in /Users/yourusername/Downloads/minecraftforge.zip do this: Open terminal cd /Users/yourusername/server mkdir mctmp cp minecraft_server.jar mctmp cd mctmp unzip minecraft_server.jar cp /Users/yourusername/Downloads/minecraftforge.zip . unzip minecraftforge.zip (if it asks you to overwrite files, say 'yes to all') rm minecraftforge.zip minecraft_server.jar zip -r ../minecraft_server.jar . cd .. And then run the server as you would normally. I don't actually use a Mac (I use Linux), but that should work. The only bit I'm unsure about is the unzip bits.
  17. If you return an empty packet on clientside, it will not show the chat.
  18. I've got a coremod which uses snakeyaml, gson and some other libraries. I'm trying to download them using one ILibrarySet, but for some reason FML seems to be stripping everything except the last section of the folder path. I'm downloading the libraries from maven, and FML prints out the libraries OK in the log: 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] There were errors during initial FML setup. Some files failed to download or were otherwise corrupted. You will need to manually obtain the following files from these download links and ensure your lib directory is clean. 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/argo-2.25.jar 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/guava-12.0.1.jar 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/asm-all-4.0.jar 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] *** Download http://repo.maven.apache.org/maven2/org/yaml/snakeyaml/1.9/snakeyaml-1.9.jar 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] *** Download http://repo.maven.apache.org/maven2/org/xerial/sqlite-jdbc/3.7.2/sqlite-jdbc-3.7.2.jar 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] *** Download http://repo.maven.apache.org/maven2/org/avaje/ebean/2.8.1/ebean-2.8.1.jar 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] *** Download http://repo.maven.apache.org/maven2/commons-lang/commons-lang/2.3/commons-lang-2.3.jar 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] *** Download http://repo.maven.apache.org/maven2/com/google/code/gson/2.2.2/gson-2.2.2.jar 2012-10-13 17:23:36 [sEVERE] [ForgeModLoader] <===========> But when it's downloading them, it shortens it to http://repo.maven.apache.org/maven2/snakeyaml-1.9.jar, for instance. So to fix this do I have to submit a patch, or am I just doing something wrong? And here's the log: EDIT: I submitted a pull request to FML which fixes this...
  19. FMLClientHandler.getMinecraftInstance(). Not FMLCommonHandler
  20. Or you could try using @SideOnly(Side="CLIENT") @Override public boolean interact(EntityPlayer entityplayer) { if (this.riddenByEntity == null) { mountEntity(entityplayer); } return true; } Or you could check which side you're on using @Override public boolean interact(EntityPlayer entityplayer) { if (FMLCommonHandler.getEffectiveSide() == Side.CLIENT) { if (this.riddenByEntity == null) { mountEntity(entityplayer); } return true; } }
  21. I'm writing a mod that adds commands to the server, and I want to add noclip. I noticed EntityPlayer has a noclip field, and I'm aware that if I want the client to act on it, I need to send the client a packet with the changed EntityPlayer. Which packet should I use? Or do I have to use a Packet250?
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.