• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hi all,   I created a custom dimension. I want to add caves to the biomes in the dimension, but  this.addCarver(GenerationStage.Carving.AIR, Biome.createCarver(WorldCarver.CAVE, new ProbabilityConfig(0.5f))); and DefaultBiomeFeatures.addCarvers(this); both were not working. I dug a bit deeper and found that the vanilla carvers are hard coded into what they can dig in: protected Set<Block> carvableBlocks = ImmutableSet.of(Blocks.STONE, Blocks.GRANITE, Blocks.DIORITE, Blocks.ANDESITE, Blocks.DIRT, Blocks.COARSE_DIRT, Blocks.PODZOL, Blocks.GRASS_BLOCK, Blocks.TERRACOTTA, Blocks.WHITE_TERRACOTTA, Blocks.ORANGE_TERRACOTTA, Blocks.MAGENTA_TERRACOTTA, Blocks.LIGHT_BLUE_TERRACOTTA, Blocks.YELLOW_TERRACOTTA, Blocks.LIME_TERRACOTTA, Blocks.PINK_TERRACOTTA, Blocks.GRAY_TERRACOTTA, Blocks.LIGHT_GRAY_TERRACOTTA, Blocks.CYAN_TERRACOTTA, Blocks.PURPLE_TERRACOTTA, Blocks.BLUE_TERRACOTTA, Blocks.BROWN_TERRACOTTA, Blocks.GREEN_TERRACOTTA, Blocks.RED_TERRACOTTA, Blocks.BLACK_TERRACOTTA, Blocks.SANDSTONE, Blocks.RED_SANDSTONE, Blocks.MYCELIUM, Blocks.SNOW, Blocks.PACKED_ICE); protected boolean isCarvable(BlockState p_222706_1_) { return this.carvableBlocks.contains(p_222706_1_.getBlock()); } protected boolean canCarveBlock(BlockState state, BlockState aboveState) { Block block = state.getBlock(); return this.isCarvable(state) || (block == Blocks.SAND || block == Blocks.GRAVEL) && !aboveState.getFluidState().isTagged(FluidTags.WATER); }   I'm trying to recreate the class on my own, could use some assistance... I'll keep you all posted.
    • I have been scrambling 4 different people's heads today trying to find a fix to this, to no avail. Basically, I have downloaded the newest version of forge for 1.16.1 to play with my friends on their server and as soon as I clicked play it crashed. I have tried many things to fix this and it seems that different versions like 1.15.2, 1.14, etc also crash, while older versions like 1.12.2, 1.8.9, etc don't. Any help would be greatly appreciated.
    • Every time I attempt to install forge to Minecraft, one file refuses to work. I've tried restarting my computer, trying different forge versions (for 1.8.9 by the way) and I honestly don't know what to do at this point. If anyone has suggestions please tell me!!
    • Around one month ago, i was playing rlcraft until suddenly it crashed on loadingentityrenderer. Sometimes I can get on the title screen, but no further then that. I have recently tried got into minecraft modding, but same thing happens there. I followed this tutorial, https://www.youtube.com/watch?v=rmWBP5ifDlw&t=410s but i don't know if this is the cause. the crashing happened around the time that i finished the first tutorial. here is the end of the crash log. I can't upload the whole thing because it says -200 and i think its an error. [B#590]  [17:27:56] [Sound Library Loader/INFO]: Starting up SoundSystem... [B#590]  [17:27:56] [Thread-8/INFO]: Initializing LWJGL OpenAL [B#590]  [17:27:56] [Thread-8/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org) [B#590]  [17:27:56] [Thread-8/INFO]: OpenAL initialized. [B#590]  [17:27:56] [Client thread/INFO]: [pl.asie.foamfix.coremod.FoamFixTransformer:spliceClasses:111]: Spliced in METHOD: net.minecraftforge.client.model.ModelLoader$VanillaModelWrapper.bakeNormal [B#590]  [17:27:56] [Sound Library Loader/INFO]: Sound engine started [B#590]  [17:28:11] [Client thread/WARN]: Unable to resolve texture due to upward reference: #item in traverse:models/block/itemblock [B#590]  [17:28:11] [Client thread/INFO]: [BetterFoliage] Registered 5 grass textures [B#590]  [17:28:11] [Client thread/INFO]: [BetterFoliage] Registered 2 snowed grass textures [B#590]  [17:28:11] [Client thread/INFO]: [BetterFoliage] Registered 4 mycelium textures [B#590]  [17:28:11] [Client thread/INFO]: [BetterFoliage] Registered 2 cactus arm textures [B#590]  [17:28:11] [Client thread/INFO]: [BetterFoliage] Registered 3 lilypad root textures [B#590]  [17:28:11] [Client thread/INFO]: [BetterFoliage] Registered 2 lilypad flower textures [B#590]  [17:28:12] [Client thread/INFO]: [BetterFoliage] Registered 4 reed textures [B#590]  [17:28:12] [Client thread/INFO]: [BetterFoliage] Registered 4 algae textures [B#590]  [17:28:12] [Client thread/INFO]: [BetterFoliage] Registered 6 coral textures [B#590]  [17:28:12] [Client thread/INFO]: [BetterFoliage] Registered 4 coral crust textures [B#590]  [17:28:12] [Client thread/INFO]: [BetterFoliage] Registered 3 netherrack textures [B#590]  [17:28:12] [Client thread/INFO]: [BetterFoliage] Registered 2 soul particle textures [B#590]  [17:28:12] [Client thread/INFO]: Max texture size: 8192 [B#590]  [17:28:21] [Client thread/INFO]: Created: 2048x1024 textures-atlas [B#590]  [17:28:22] [Client thread/ERROR]: MultiModel minecraft:builtin/missing is empty (no base model or parts were provided/resolved) [B#590]  [17:28:22] [Client thread/ERROR]: MultiModel minecraft:builtin/missing is empty (no base model or parts were provided/resolved) [B#590]  [17:28:23] [Client thread/INFO]: Clearing ModelLoaderRegistry cache (16534 items)... [B#590]  [17:28:23] [Client thread/INFO]: Cleared 16529 objects. [B#590]  [17:28:23] [Client thread/INFO]: Deduplicating models... [B#590]  [17:28:23] [Client thread/INFO]: Deduplicating models... [B#590]  [17:28:24] [Client thread/INFO]: Deduplicated 106720 (+ 43837) objects. [B#590]  [17:28:28] [Client thread/INFO]: Found method net.minecraft.client.renderer.chunk.RenderChunk.func_178581_b (FFFLnet/minecraft/client/renderer/chunk/ChunkCompileTaskGenerator;)V (matching rebuildChunk) [B#590]  [17:28:28] [Client thread/INFO]: [BetterFoliageLoader] Applying RenderChunk block render override [B#590]  [17:28:28] [Client thread/INFO]: [BetterFoliageLoader] Applying RenderChunk block layer override [B#590]  # [B#590]  # A fatal error has been detected by the Java Runtime Environment: [B#590]  # [B#590]  #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000325bf1cb60, pid=2540, tid=0x00000000000022d0 [B#590]  # [B#590]  # JRE version: Java(TM) SE Runtime Environment (8.0_261-b12) (build 1.8.0_261-b12) [B#590]  # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.261-b12 mixed mode windows-amd64 compressed oops) [B#590]  # Problematic frame: [B#590]  # C  [ig75icd64.dll+0x1cb60] [B#590]  # [B#590]  # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows [B#590]  # [B#590]  # An error report file with more information is saved as: [B#590]  # C:\Users\didi\AppData\Roaming\.technic\modpacks\shivaxi-rlcraft\hs_err_pid2540.log [B#590]  # [B#590]  # If you would like to submit a bug report, please visit: [B#590]  #   http://bugreport.java.com/bugreport/crash.jsp [B#590]  # The crash happened outside the Java Virtual Machine in native code. [B#590]  # See problematic frame for where to report the bug. [B#590]  # [B#590]  AL lib: (EE) alc_cleanup: 1 device not closed [B#590] Starting download of http://cdn.technicpack.net/platform2/pack-icons/1530385.png?1588115247, with 3 tries remaining  
    • Launcher.log -> https://paste.gg/p/anonymous/126c82ea07504cb5b9bc779e900de9ba Debug.log -> https://paste.ee/p/VCnOC#s=0&l=3134   Everytime i load up mc forge on any version i get this Failed to download file. Name: forge-1.16.1-32.0.98.jar Filename on disk: forge-1.16.1-32.0.98.jar Path: C:\Users\ezeki\AppData\Roaming\.minecraft\libraries\net\minecraftforge\forge\1.16.1-32.0.98\forge-1.16.1-32.0.98.jar Exists: Nonexistent
  • Topics

  • Who's Online (See full list)