Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forums Migration/Upgrade


Guest Mr. Flamegoat
 Share

Recommended Posts

Guest Mr. Flamegoat

EDIT: Forums migration is COMPLETE!

 

However - there is much to do and it has been a very long day for me.

  • Fix the stylesheets - they're wonky and the text sizes and such are all off (WHERE'S PALEO?!)
  • Fix redirects to old content urls (they don't break, but they're not going where they should.
  • Clean up SEO
  • FIX THE MILLION THINGS I KNOW YOU GUYS WILL FIND

I'm too tired for a proper post migration post.

 

Let me have it. Let's find out what's left to clean up together. :]

Link to comment
Share on other sites

Guest Mr. Flamegoat

 

2 minutes ago, TheDarkPreacher said:

found something. trying to view posts, getting error code 2S136/V

 

Post the link - it may be an old link. I have to run some fixes tomorrow that should clear that up - I didn't get as much help from the crew that was managing this migration as I thought :\ 

 

One man warrior!

Link to comment
Share on other sites

Guest Mr. Flamegoat

Hrm - it could be caching and crons still running. I have to get some sleep. Been an 18 hour day so far. Please let me know if you find anything else! 

Link to comment
Share on other sites

Some issues I've noticed:

 

  • Almost all avatars appear to be missing (TheDarkPreacher's is the only one I've seen so far)
  • Attempting to upload an avatar fails, with the message "There is no profile photo available to crop  Error code: 2C138/C". The URL is http://www.minecraftforge.net/forum/index.php?/profile/70776-choonster/&do=cropPhoto.
  • The [tt] tag was previously used for inline code, now it's being displayed as a code block on a new line.
  • I can't edit any of my posts made before the migration. I'm not sure if this is a bug or a time limit.
  • There doesn't appear to be any distinction between read and unread threads.

 

It's not really a migration issue, but is there any way to disable the popup and/or sound for new replies while viewing a thread?

Edited by Choonster

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Guest Mr. Flamegoat
3 minutes ago, Choonster said:

Some issues I've noticed:

 

  • Almost all avatars appear to be missing (TheDarkPreacher's is the only one I've seen so far)
  • Attempting to upload an avatar fails, with the message "There is no profile photo available to crop  Error code: 2C138/C". The URL is http://www.minecraftforge.net/forum/index.php?/profile/70776-choonster/&do=cropPhoto.
  • The [tt] tag was previously used for inline code, now it's being displayed as a code block on a new line.

It's not really a migration issue, but is there any way to disable the popup and/or sound for new replies while viewing a thread?

 

Will look into all of these first thing in the morning. I noticed the avatars - but that's an easy fix. A few of the migration pieces I figured I'd have to tackle myself anyways.

Not sure about the profile photo issue either.

Lol don't like the ding ding ding?

Link to comment
Share on other sites

I can confirm that using a PNG avatar works, though using a JPEG one should either work or result in a better error message.

 

It looks like there's a time limit on edits, since I can't edit my previous post in this thread. This is a bit annoying, I'd prefer not to have the time limit.

 

Contrary to my previous post, there is a distinction between read and unread threads, I just didn't have any unread ones.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Guest Mr. Flamegoat
1 hour ago, Choonster said:

I can confirm that using a PNG avatar works, though using a JPEG one should either work or result in a better error message.

 

It looks like there's a time limit on edits, since I can't edit my previous post in this thread. This is a bit annoying, I'd prefer not to have the time limit.

 

Contrary to my previous post, there is a distinction between read and unread threads, I just didn't have any unread ones.

 

2 hours ago, Aeronica said:

I tried using a 200x200 jpg file but that failed. I then converted it to a png file and used that. The crop tool displayed the image. I saved and these it is.

 

Interesting - I'll dig into this after work.

 

51 minutes ago, quadraxis said:

Code blocks, quotes and text boxes all have really low contrast for text using the dark theme.

 

 

I'll let our designer know :]

Link to comment
Share on other sites

A few things I've noticed:

  • Editing directly using BBCode doesn't work (is the forum still going to use BBCode or something else?). This means some tags like [tt] and [nobbc] don't work anymore, while the [.code]tag does work. I'd rather see all the tags working like before instead of some working and some don't. One of the main things I've missed is the inline code tag ([tt]), 
  • Code blocks keep getting bigger after 10 lines of code, instead of getting a scrollbar, making posts like this and this extremely long while it shouldn't have to be.
  • For me, the header and footer continue all the way to the right, while the "body" part (threads and comments) don't. I don't know if this is intentional or a styling issue.

Overall, I like the new design. It's got some design flaws, which may or may not be specific to me. If you want to hear them, I'll post them here or in a PM if you want.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

Guest Mr. Flamegoat

Removed the edit time restriction.

Regarding BBCode, I'll review our options and the code block might be something we can do with stylesheets and max height.

Link to comment
Share on other sites

Guest Mr. Flamegoat

Oh that's a nice one - I'll ask Paleo about it.

 

22 hours ago, shadowfacts said:

All the ranks (the Stone Miner thing not the Forge Modder one) have reset except for a couple people (you and Lex are the only one's I've noticed).

 

Fixed

Link to comment
Share on other sites

This is probably just a choice of you guys, but on your profile you can't see how many post a day someone has made...

I'd really like if you added it again :D.

Also, if you're using the dark theme it is really hard to see what you're typing...c7cc6fb961b8d4c0656228ffd59ecccf.png

Edited by Kokkie

Classes: 94

Lines of code: 12173

Other files: 206

Github repo: https://github.com/KokkieBeer/DeGeweldigeMod

Link to comment
Share on other sites

Guest Mr. Flamegoat
19 hours ago, Leomelonseeds said:

There doesn't seem to be a link to view all posts in one page if there are multiple pages.

 

That's terrible for databases and won't ever be a thing - I consider that a broken feature. Pagination is bae.

 

7 hours ago, Kokkie said:

This is probably just a choice of you guys, but on your profile you can't see how many post a day someone has made...

I'd really like if you added it again :D.

Also, if you're using the dark theme it is really hard to see what you're typing...c7cc6fb961b8d4c0656228ffd59ecccf.png

 

Different forum software, just doesn't have this feature out of the box. May add more stats for users later, but focusing on content and usability first.

 

6 hours ago, Egietje said:

Everybody is unbanned?

At least I am...

I guess jay?

 

Not everyone. Bans were transferred over, but some were corrupted or strange because SMF was effectively broken when it came to permissions. So don't get re-banned.

 

3 hours ago, MoeBoy76 said:

My issue with unread forums/threads not displaying as different on my phone is now resolved, not sure if you did anything or if it had to do with me hitting the new "mark forums as read" on my PC last night but thanks for the hard work nonetheless 

 

Cool! Making small tweaks constantly, not sure what I may have done to fix it, but glad it's resolved.

 

Link to comment
Share on other sites

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.